Engine

Studio Interface

Toolbar

The toolbar resides at the top of Studio. The buttons and tools visible in the bar change when you click on the Home, Model, Avatar, Test, View, and Plugins tabs.

Primary tabs in Studio toolbar

The Home tab contains basic tools for manipulating 3D objects and testing your experience.

The Model tab contains tools for manipulating 3D objects in the workspace, creating detailed models, working with physical constraints, and adding advanced objects.

The Avatar tab contains specialized tools for creating and fitting accessories, importing custom meshes, building default rigs, and creating animations.

The Test tab contains tools for testing an experience, simulating multiple clients, and emulating different devices.

The View tab lets you toggle the various windows of Studio, as well as several display features.

The Plugins tab contains tools for managing plugins, configuring localization, and creating animations. Any plugins you install can also add buttons to this tab.

3D Viewport

The 3D viewport represents the Workspace of a place. From here, you can move the camera around the virtual world, manipulate objects with the mouse, and playtest an experience without leaving Studio.

3D viewport in Roblox Studio
3D viewport in Roblox Studio

Camera Controls

Inside the viewport, you can move the camera with the following controls:

Keys/ShortcutsAction
W A S DMoves the camera forward/left/back/right.
Q EMoves the camera down/up.
ShiftIn combination with any movement key, changes the camera speed. If desired, you can customize the camera speed within Studio's settings.
FFocuses the camera on a selected part.
Right Mouse ButtonWhen pressed, dragging the mouse moves the camera view around.
Mouse Scroll WheelZooms the camera in or out.
Middle Mouse ButtonWhen pressed, dragging the mouse pans the camera.

Selecting Objects

As you hover over parts and models in the viewport, they are outlined to indicate their potential selection. You can select an outlined object by clicking it, or you can select multiple objects by holding Shift, Ctrl, or as you hover over and click them.

Multiple models selected in 3D viewport

Selection Cycling

In more complex environments or when zoomed in, objects will commonly be hidden from your view by other objects in front. To select hidden objects without moving the camera around, hold Alt or and click to perform selection cycling to the next further object behind the currently selected object.

Selection cycling

Children or Parents

When one or more objects or models are selected in the Explorer window, you can select all of their children by right-clicking and choosing Select Children from the context menu. Similarly, right-clicking and choosing Select Parent(s) selects the direct parents of those objects.

Selection Style

To display outlines and/or bounding boxes around selected objects, choose an option from the Selection Style menu in the View tab.

Selection Style menu indicated in View tab of Studio Selected part showing both its selection outline and a bounding box

Common Windows

You can toggle on commonly used windows through the View tab, including the Explorer window, Properties window, Asset Manager, Toolbox, and many others.

View tab indicated in Studio toolbar

Explorer

The Explorer window, visible by default, shows a hierarchical list of every object and service inside the place, collectively referred to as its data model. Frequently used services in the hierarchy include Workspace which mirrors the 3D viewport, as well as ReplicatedStorage and ServerStorage.

Explorer toggle button in Studio Explorer window in Studio

Properties

The Properties window lets you adjust properties of a selected object to change how it looks and behaves. Object properties are divided into sections; for example, a MeshPart includes sections like Appearance which allows you to change its color, material, transparency, and more.

Properties toggle button in Studio Properties window in Studio

At the bottom of the window, you can define custom attributes for an object, similar to its default properties. Attributes and their values are saved with your place/assets and they're an ideal way for team members to experiment with different values during runtime, even if they don't understand the underlying code.

Asset Manager

The Asset Manager lets you manage places, images, meshes, packages, audio, and models in your experience. It also provides a mechanism to bulk import large groups of assets.

Asset Manager toggle button in Studio Asset Manager window in Studio

Toolbox

The Toolbox contains a selection of models, images, meshes, audio, plugins, videos, and fonts made by Roblox or Roblox community members. It also includes all of the creations that you've personally published or those which were published by groups you belong to.

Toolbox toggle button in Studio Toolbox window in Studio

Output Window

The Output window, accessible from the View tab, displays errors captured from running scripts, messages from Roblox engine, messages from calls to print(), and errors from calls to warn(). See Output Window for further details.

Output button indicated in View tab of Studio

Command Bar

The Command Bar, accessible from the View tab, lets you execute Luau code outside of scripts. Similar to a terminal, pressing or while using the command bar navigates up and down among previously-executed commands. Clicking the small arrow on the right side similarly reveals a list of previously-executed commands.

Command Bar button indicated in View tab of Studio

Saving & Publishing

Options to save and publish can be found in the File menu in the top left of Studio.

OptionAction
Save to FileSave the experience locally to your computer in .rbxl format.
Save to RobloxSave the experience to Roblox's cloud storage. Unlike Publish to Roblox, this does not update the current live version of the experience.
Publish to RobloxSave and publish the experience to Roblox so other users can play. For more information, see Publishing Experiences and Places.

In-Studio Testing

Studio offers a suite of options for testing an experience before releasing it to the public. All of the testing options are accessible from the Test tab.

  • Rapid playtesting that provides a close simulation of the experience running on the Roblox application.

    Rapid playtest options in Test tab of Studio
  • Multi-client simulation for comparing how each client "sees" other clients within the experience.

  • Device emulation that provides insight on how controls operate on a mobile device or how on-screen UI displays on different screens and aspect ratios.

  • Collaborative playtesting with members of your team group.

See Studio Testing Modes for more information on each testing option.