툴바와 메자닌
툴바와 메자닌은 스튜디오의 상단에 위치합니다.

메자닌의 왼쪽에는 쉽게 접근할 수 있는 테스트 컨트롤이 있습니다.

메자닌의 오른쪽에는 협업, 공유, 어시스턴트, 제작자 알림 및 계정 옵션을 위한 버튼/메뉴가 있습니다.

메자닌의 중앙에는 홈, 모델, 아바타, UI, 스크립트, 플러그인의 기본 도구 탭이 있습니다. 특정 요구에 맞는 사용자 정의 탭도 추가할 수 있습니다.

홈 탭에는 핵심 변환 도구, 부품 삽입기, 색상 및 재질 위젯, 그룹 및 잠금 도구, 앵커 토글이 포함되어 있습니다. 또한 지형 편집기도 포함되어 있습니다.
외관
툴바의 외관은 메자닌/툴바의 빈 영역을 마우스 오른쪽 버튼으로 클릭하고 다음 옵션 중에서 선택하여 사용자 정의할 수 있습니다:
탭 관리 — 다음 옵션이 포함된 팝업 창을 표시합니다:

- 탭을 표시하거나 숨깁니다.
- 선택한 탭을 다른 탭에 대해 재정렬합니다.
- 선택한 사용자 정의 탭을 삭제합니다.
- 탭 중앙 정렬 또는 왼쪽 정렬(테스트 컨트롤 옆에) 중에서 선택합니다.
툴바 축소 — 툴바를 숨겨 공간을 극대화하지만 메자닌은 계속 표시됩니다. 메자닌의 탭 위에 마우스를 올리면 툴바가 일시적으로 표시됩니다.
콤팩트 툴바 — 아이콘과 레이블을 작게 하여 툴바를 상당히 콤팩트하게 만들어 노트북이나 작은 모니터에 적합합니다.
레이블 표시 — 도구 아래의 텍스트 레이블을 켜거나 끕니다.
사용자 정의 탭
기본 도구 탭 외에도 특정 요구에 맞는 사용자 정의 탭을 추가할 수 있습니다. 이는 스튜디오의 인터페이스를 통해 하거나 로컬 .json 파일을 편집하여 수행할 수 있습니다.
사용자 정의 탭을 만드는 가장 쉬운 방법은 스튜디오의 워크플로우를 사용하는 것입니다.
기본 탭 오른쪽에 있는 + 버튼을 클릭한 다음 새 탭의 이름을 입력하고 Enter를 누릅니다.

버튼을 클릭하거나 툴바의 빈 영역을 마우스 오른쪽 버튼으로 클릭하고 도구 추가를 선택합니다.

팝업 창에서 도구를 검색하고 체크박스를 토글하여 추가합니다. 새 도구는 다른 도구의 오른쪽에 나타나지만, 원하는 도구를 마우스 오른쪽 버튼으로 클릭하고 왼쪽으로 이동 또는 오른쪽으로 이동을 선택하여 다른 도구에 대해 재정렬할 수 있습니다. 또한 툴바의 빈 영역을 마우스 오른쪽 버튼으로 클릭하고 구분선 추가를 선택하여 구분선을 삽입할 수 있습니다.

3D 뷰포트
3D 뷰포트는 장소의 Workspace를 나타냅니다. 여기에서 가상 세계를 돌아다니고, 마우스로 객체를 조작하며, 스튜디오를 떠나지 않고 게임을 플레이 테스트할 수 있습니다.

카메라 컨트롤
뷰포트 내에서 다음 컨트롤을 사용하여 카메라를 이동할 수 있습니다.
| 키/단축키 | 동작 |
|---|---|
| W A S D | 카메라를 앞으로/왼쪽으로/뒤로/오른쪽으로 이동합니다. |
| Q E | 카메라를 아래로/위로 이동합니다. |
| Shift | 어떤 이동 키와 조합하여 카메라 속도를 변경합니다. |
| F | 선택된 부품에 카메라를 집중시킵니다. |
| 마우스 오른쪽 버튼 | 누르면, 마우스를 드래그하여 카메라 뷰를 이동합니다. |
| 마우스 스크롤 휠 Ctrl= 또는 ⌘= Ctrl- 또는 ⌘- 또는 O | 카메라를 확대하거나 축소합니다. 카메라를 확대합니다. 카메라를 축소합니다. |
| , / . | 카메라를 왼쪽/오른쪽으로 회전합니다. 부품/모델이 F 단축키를 통해 초점이 맞춰져 있다면, 그 초점 맞춘 객체 주위를 반시계 방향/시계 방향으로 회전합니다. |
| 마우스 가운데 버튼 | 누르면, 마우스를 드래그하여 카메라를 패닝합니다. |
| 마우스 오른쪽 버튼 & 마우스 스크롤 휠 | 오른쪽 마우스 버튼을 누르고 마우스 휠을 위로 스크롤하면 카메라 스크롤 속도가 증가합니다. 반대로, 오른쪽 마우스 버튼을 누르고 마우스 휠을 아래로 스크롤하면 카메라 스크롤 속도가 감소합니다. |
객체 선택
뷰포트에서 부품과 모델 위에 마우스를 올리면 선택 가능성을 나타내기 위해 윤곽선이 표시됩니다. 윤곽선이 있는 객체를 클릭하여 선택할 수 있으며, Shift, Ctrl, 또는 ⌘를 누른 채로 여러 객체를 선택할 수 있습니다.

더 복잡한 환경이나 확대된 경우, 다른 객체에 의해 객체가 가려질 수 있습니다. 카메라를 이동하지 않고 숨겨진 객체를 선택하려면 Alt 또는 ⌥를 누른 채 클릭하여 현재 선택된 객체 뒤에 있는 다음 객체로 선택 순환을 수행합니다.
객체 주위의 선택 선과 상자의 외관을 사용자 정의하려면 스튜디오 설정의 선택 패널 내 선택 시각화 섹션에서 원하는 옵션을 설정합니다.

시각화 옵션
3D 뷰포트의 오른쪽 상단 모서리에서 화면 UI 오버레이, 광원, 물리 시뮬레이션, 캐릭터 경로 찾기 등과 관련된 일반적인 시각화 옵션을 빠르게 전환하거나 설정할 수 있습니다. 메뉴에는 카메라 스크롤 속도를 보기/설정하는 컨트롤도 포함되어 있습니다.

자주 사용하는 도구
자주 사용하는 창에는 탐색기, 속성 창, 자산 관리자, 툴박스 등이 포함됩니다.
탐색기
탐색기 창은 기본적으로 표시되며 스튜디오의 창 메뉴 또는 홈 탭에서 접근할 수 있으며, 장소 내의 모든 객체와 서비스의 계층 목록을 보여줍니다. 이를 데이터 모델이라고 합니다. 계층에서 자주 사용되는 서비스에는 3D 뷰포트를 반영하는 Workspace, ReplicatedStorage, ServerStorage가 포함됩니다.

속성
속성 창은 기본적으로 표시되며 스튜디오의 창 메뉴 또는 홈 탭에서 접근할 수 있으며, 선택한 객체의 속성을 조정하여 외관과 동작을 변경할 수 있습니다. 객체 속성은 섹션으로 나뉘어 있으며, 예를 들어 MeshPart는 색상, 재질, 투명도 등을 변경할 수 있는 외관 섹션을 포함합니다.

창 하단에서는 객체에 대한 사용자 정의 속성을 정의할 수 있으며, 이는 기본 속성과 유사합니다. 속성과 그 값은 장소/자산과 함께 저장되며, 팀원이 런타임 동안 다양한 값을 실험할 수 있는 이상적인 방법입니다.

자산 관리자
자산 관리자는 스튜디오의 창 메뉴 또는 홈 탭에서 접근할 수 있으며, 장소, 이미지, 메시, 오디오 등을 관리할 수 있습니다. 또한 대량의 자산을 한 번에 가져오는 메커니즘도 제공합니다.
툴박스
툴박스는 스튜디오의 창 메뉴 또는 홈 탭에서 접근할 수 있으며, Roblox 또는 Roblox 커뮤니티 구성원이 만든 모델, 이미지, 메시, 오디오, 플러그인, 비디오 및 글꼴을 포함합니다. 또한 사용자가 개인적으로 제작자 상점에서 배포한 모든 창작물이나 소속된 그룹에서 배포한 창작물도 포함됩니다.

출력
출력 창은 스튜디오의 창 메뉴 또는 스크립트 탭에서 접근할 수 있으며, 실행 중인 스크립트에서 캡처된 오류, Roblox 엔진의 메시지, print() 호출의 메시지, warn() 호출의 오류를 표시합니다.
명령어 바
명령어 바는 스튜디오의 스크립트 탭 툴바 또는 창 ⟩ 스크립트 메뉴에서 접근할 수 있으며, 스크립트 외부에서 Luau 코드를 실행할 수 있습니다. 언제든지 명령어 바로 빠르게 이동하려면 Ctrl9 (Windows) 또는 ⌘9 (Mac)을 누릅니다.

기능은 다음과 같습니다:
다중 행 편집 — 입력 중 Enter를 눌러 새 줄을 삽입합니다. 바는 2줄로 시작하며, 새 줄이 삽입될 때 최대 10줄까지 커지고, 줄이 삭제되면 줄 수가 줄어듭니다. 바의 내용을 실행할 준비가 되면 실행 버튼을 클릭하거나 단축키 CtrlEnter (⌘Enter)를 사용합니다.
명령어 기록 — 마지막 10개의 실행된 명령어는 기록 버튼을 클릭하고 최근 탭으로 이동하여 볼 수 있습니다. 목록에서 명령어를 클릭하면 바에 로드되며, ↑/↓로 목록을 탐색하고 Enter로 강조된 명령어를 삽입할 수 있습니다. 또는 명령어 바가 선택된 상태에서 Ctrl/⌘ + ↑/↓를 사용하여 명령어를 스크럽할 수 있습니다.
저장된 명령어 — 저장 버튼이나 기본 단축키 CtrlB (⌘B)를 사용하여 명령어를 명시적으로 저장할 수 있습니다. 저장된 명령어는 팝업 목록의 저장된 탭에서 접근할 수 있으며, 저장된 명령어를 목록에서 로드하는 메커니즘은 명령어 기록과 동일합니다.
레이아웃 사용자 정의
스튜디오의 드래그 앤 드롭 인터페이스를 사용하면 작업 흐름에 가장 적합한 창 레이아웃을 쉽게 사용자 정의할 수 있습니다.
창 재배치
헤더 바를 클릭하고 드래그하여 모든 창의 위치를 재배치할 수 있습니다. 창을 드래그하기 시작하면 인터페이스가 빈 도킹 영역을 표시합니다. 마우스 포인터를 빈 영역으로 드래그하면 해당 영역에 떠 있는 위치 선택기가 나타납니다. 떠 있는 선택기의 "중앙" 위로 포인터를 드래그하면 드래그된 창의 대상이 되는 빈 영역이 선택되며, 해당 영역이 어두워지고 윤곽선이 표시됩니다.

마우스 포인터를 3D 뷰포트와 같은 채워진 영역으로 드래그하면, 창의 대상에 대한 여러 옵션이 있는 떠 있는 위치 선택기가 나타납니다. 예를 들어, 포인터를 "왼쪽" 아이콘 위로 드래그하면 창이 해당 영역의 왼쪽에 위치하게 됩니다.

창 그룹화
창을 채워진 영역으로 드래그하고 위치 선택기의 "중앙" 아이콘을 선택하면 드래그된 창이 해당 영역에 탭으로 그룹화됩니다. 이를 통해 자주 사용하는 창의 탭 그룹을 설정할 수 있습니다.

창 고정
3D 뷰포트의 화면 공간을 극대화하기 위해, 창(또는 전체 창 그룹)을 스튜디오 창의 가장자리에 고정할 수 있습니다. 고정된 후에는 탭을 클릭하여 임시로 창을 열 수 있으며, 이는 다른 창에 방해가 되지 않으며, 다른 창을 클릭하거나 탭을 다시 클릭하면 확장된 창이 자동으로 축소됩니다.

창이나 전체 창 그룹을 고정하려면 "축소" 버튼을 클릭합니다. 또는 고정된 창/그룹의 고정을 해제하려면 탭을 클릭하여 열고 "확장" 버튼을 클릭합니다.

창 떠있기
다른 창과 자유롭게 떠 있는 창을 만들려면, 떠 있는 위치 선택기에서 아이콘을 선택하지 않고 드래그 앤 드롭하면 됩니다.