サードパーティのモデリングツール、例えばBlenderやMayaを使用して、既存の3Dオブジェクトをレイヤー化可能な3Dモデルに変更し、インポートして変換してStudioにAccessoryとして使用できます。レイヤー化されたモデルを作成するには、3Dモデルをマネキンのアーマチュアに親子付け(Blender)またはバインド(Maya)し、アクセサリーモデルの内側と外側の表面にフィットするように2つの追加メッシュを修正する必要があります。
このガイドでは、Blenderで3Dモデルをレイヤー化可能なモデルに変換する基本的なワークフローを以下の手順で説明します。
- インポートする3DアセットをテンプレートのBlenderプロジェクトファイルに追加します。
- 親子付けを行い、Blenderの自動ウェイト機能を使用してインポートしたメッシュオブジェクトをプロジェクトファイルのアーマチュアリグに接続します。
- 手動スキニングはカバーしていません。手動スキニングの概要については、シンプルなメッシュをスキンするを参照してください。
- 編集して、モデルの内側と外側の表面を表すInnerとOuter Cageメッシュを作成します。
レイヤー化されたモデルのアセット要件の完全なリストは、レイヤー化モデルの仕様で確認できます。
インポート
リグテンプレートプロジェクトを開き、サンプルアクセサリーモデルをインポートしてプロジェクトを設定します。
アクセサリーモデルをインポートして親子付けするには:
Blenderでリグテンプレートプロジェクトを開きます。このファイルには、レイヤー化されたアクセサリーに必要なデフォルトのアーマチュアが含まれています。

アウトライナーで、Hideアイコンを切り替えて、作業スペース内のアタッチメントなどの非アーマチュアオブジェクトを視覚的に削除します。
ファイルメニューでインポートを選択し、**FBX (.fbx)**をクリックします。マネキンにフィットさせるアクセサリーモデルファイルを選択します。アクセサリーが作業スペースに表示され、アセットのモデリング方法によっては、マネキンにフィットさせるためにサイズ変更や調整が必要になる場合があります。
親子付けとウェイト
この基本的なアクセサリーのために、Blenderの自動ウェイト機能を使用してインポートしたメッシュをテンプレートのマネキンアーマチュアに親子付けします。この方法でアクセサリーモデルメッシュをアーマチュアに親子付けすることで、3DモデルがStudio内のキャラクターと自然に動き、変形することができます。
メッシュオブジェクトをマネキンアーマチュアに親子付けするには:
アウトライナーで、両方のCageオブジェクトを一時的に隠して、アーマチュアを表示させます。
ワークスペースでメッシュオブジェクトをクリックし、Shiftを押しながらマネキンのアーマチュアをクリックします。
右クリックするか、CtrlP(⌘P)を使用して、自動ウェイトを選択してアクセサリーをアーマチュアに親子付けします。
ケージとモデル以外のすべてのオブジェクトを隠して視覚的な混乱を減らします。アウトライナーパネルのオブジェクトの隣にある
シンボルをクリックします。
内部および外部ケージメッシュの編集
衣服アイテムの親子付けとウェイト付けが完了したら、衣服の内側と外側の表面を示すためにケージメッシュを追加し始めることができます。
ケージを設定する際、アクセサリーモデルは内側のケージの上にフィットし、その後外側のケージをモデルオブジェクトの上にしっかりとフィットさせる必要があります。
Clothing_Cage_Template.blendからこれら2つのフルボディメッシュを既存のプロジェクトに迅速に追加できます。
プロジェクトに衣服ケージを迅速に追加するには:
Clothing_Cage_Template.blendプロジェクトをダウンロードします。
現在のBlenderプロジェクトで、オブジェクトモードに切り替え、ファイル > 追加に移動します。ファイルブラウザが表示されます。

Clothing_Cage_Template.blendファイルをクリックし、オブジェクトフォルダに移動します。

オブジェクトフォルダ内でShiftを押しながらYourClothingName_InnerCageとYourClothingName_OuterCageの両方を選択し、追加をクリックします。2つのケージメッシュオブジェクトがプロジェクトに追加されます。

アクセサリーモデルのケージを修正するには:
アウトライナーパネルで、_InnerCageと**_OuterCage**メッシュの名前をインポートしたメッシュオブジェクトに合わせて変更します(例:Tshirt_InnerCage、Tshirt_OuterCage)。これがインポートしたメッシュ名と正確に一致していることを確認してください。

アウトライナーウィンドウで、_OuterCageメッシュを選択し、編集モードTabに切り替えます。
ビューポートで、X-Rayビューとマテリアルビューを有効にして、外側のケージメッシュの頂点への可視性とアクセスを改善します。
編集モードのツールを使用して、Outer Cageがアクセサリーの上部を完全に覆うように頂点を調整します。
完成した外側のケージは、アクセサリーを最小限の余白で完全に覆う必要があります。比較のために、Tshirtモデルの完成したケージバージョンをダウンロードできます。
アセットのケージとモデリングが完了したら、Blenderからモデルをエクスポートするための詳細についてはエクスポート要件を参照してください。
エクスポート後、アクセサリーフィッティングツールと衣服アクセサリーの変換チュートリアルを参照して、モデルを使用可能なアクセサリーにインポートおよび変換する手順を確認してください。
ケージ編集のためのヒント
ケージの頂点を操作する際に役立つ以下のヒントがあります:
ビューポートの右上で、必要に応じて異なるビューポートシェーディングオプション(マテリアルプレビューやX-Rayなど)を切り替えて、頂点にアクセスしやすくし、ケージの進捗を確認します。
現在調整していない頂点を隠す(H)および表示(AltH; ⌥H)ことで隠すことができます。
複数の頂点を同時に選択して調整できます。移動、スケール、または他のBlenderツールを使用して、複数の頂点を一度に調整します。