Meshes in Studio

You can insert creator-uploaded meshes or import custom meshes into Studio. Once added to your experience, you can access meshes in the Toolbox or Asset Manager and configure them in the following ways:

Inserting Meshes

Creator Marketplace

You can browse thousands of user-uploaded meshes from the Creator Marketplace through the Marketplace tab of the Toolbox.

  1. Navigate to the View tab and select Toolbox.

  2. From the Marketplace tab, select the category dropdown and choose Meshes.

  3. (Optional) Click the filter button to the right of the search bar to filter meshes by verified creators and/or a specific creator's username.

  4. In the Search field, type anything you'd like to find.

  5. Either click or drag-and-drop a mesh to insert it into the viewport.

Asset Manager

Meshes that you've personally imported or those which were imported by groups you belong to appear in the Asset Manager.

  1. Navigate to the View tab and select Asset Manager.

  2. Open the Meshes folder, then either:

    • Drag-and-drop a mesh into the 3D viewport.
    • Right-click on a mesh and select Insert, or select Insert With Location if you'd like to preserve mesh location data that was stored during the import process.

Importing Meshes

You can import standard meshes through the Asset Manager, or rigged/skinned meshes through the Avatar Importer. All imported meshes must adhere to Studio's mesh requirements.

Standard

To import one or more standard meshes through the Asset Manager:

  1. Click the Bulk Import button.

  2. Select the meshes you want to import from your local machine, then click the Open button.

  3. For each mesh being imported, set the applicable options listed below and click Apply, or select Apply All to apply your choices to every mesh.

    • Rescale if too large
    • Reverse inward-pointing mesh normals
    • Import file as single mesh

After a moment, the meshes display with a status icon. Successfully imported meshes enter the moderation queue and are only visible to you within the Meshes folder of the Asset Manager and in the Creations tab of the Toolbox.

Rigged/Skinned

Meshes that are rigged or skinned must be imported as a .fbx file through the Avatar Importer.

  1. In the menu bar, navigate to the Plugins tab and click Avatar Importer.

  2. Select Custom. A file browser displays.

  3. Select the rigged mesh you want to import. The mesh displays in your workspace.

Adding Textures

Image Textures

Image textures wrap around a 3D mesh. Most meshes already include textures, although textures can be changed or altered by changing the TextureID field to an appropriate image asset ID.

To apply a mesh texture in Studio:

  1. Within the Explorer window, select the MeshPart object.

  2. In the Properties window, select the TextureID field.

  3. Enter a new texture ID or locate a specific texture.

Surface Appearance

You can use the SurfaceAppearance instance to override a mesh's TextureID with advanced PBR textures, including color, normal, metal, and roughness maps. See Surface Appearance for details.

ColorMap
NormalMap
MetalnessMap
RoughnessMap

Collision Fidelity

The CollisionFidelity property determines how closely the visual representation of the object matches the physical bounds, or hitbox, of the object. By changing the CollisionFidelity property, you can change how far away a user has to be from a mesh until they collide with each other.

See Detecting Collisions for an approximation of the CollisionFidelity options and outcomes.

Level of Detail

By default, meshes will always display in precise fidelity, no matter how far they are from the camera, but you can dynamically control a mesh's level of detail through its RenderFidelity property. Setting less important meshes to a lower render fidelity will improve an experience's performance if you have many detailed meshes. When it is set to Automatic, the mesh renders at a different level of detail of detail depending on its distance from the camera:

Distance From Camera Render Fidelity Example
Less than 250 studs Highest
250-500 studs Medium
500 or more studs Lowest

Posing and Animating

Rigged meshes contain Bone instances that you can rotate and position to articulate your mesh at different points. These bones and their inherited influences are identical to their Blender or Maya counterparts.

To pose a rigged mesh in Studio:

  1. In the Explorer window, select the imported mesh and expand its child instances to access the bones.

  2. Select a bone and rotate it to pose the model along the created bone joints.

You can animate a rigged mesh using the Animation Editor, and the mesh object's Bones display as options you can add to the animation track.

To animate a rigged mesh in Studio:

  1. Open the Animation Editor.

  2. Select the mesh object in the workspace.

  3. In the timeline, navigate to the ⊕ icon and click Add All to add all the created bones to the animation.

  4. Test and animate your new rig by applying transforms to the specific bones you've created. See Animation for additional instructions on animating.