Rig một mô hình người

*Nội dung này được dịch bằng AI (Beta) và có thể có lỗi. Để xem trang này bằng tiếng Anh, hãy nhấp vào đây.

Một mô hình nhân vật người R15, chẳng hạn như những mô hình tạo thành nhân vật avatar của người dùng, được tạo thành từ 15 đối tượng lưới riêng biệt. Tương tự như việc rig một lưới đơn giản, bạn có thể liên kết hoặc làm cha một nhóm lưới với một rig nội bộ. Các mô hình được tạo thành từ nhiều lưới yêu cầu các bước bổ sung để rig trong một công cụ mô hình hóa bên thứ ba như Blender hoặc Maya.

Hướng dẫn nâng cao này bao gồm quy trình rig một mô hình người trong Blender bằng cách sử dụng một mẫu và mô hình người đã cung cấp. Bước rig này là cần thiết trước khi skin mô hình người. Bạn nên quen thuộc với rig một mô hình cơ bản trước khi tiếp tục.

Để rig một mô hình người trong Blender:

Thiết lập Blender

Để bắt đầu tạo một lưới người đã rig, trước tiên hãy thiết lập các điều sau trong dự án Blender của bạn:

  • Nhập mô hình nhân vật Lola vào dự án Mannequin Template Blender.
  • Thiết lập Hình ảnh xem của bạn để tối ưu hóa quy trình rig.

Nhập mô hình

Khi rig một mô hình, hãy đảm bảo rằng mô hình nhân vật bạn đang sử dụng tuân theo Thông số kỹ thuật nhân vật Avatar của Studio. Đối với hướng dẫn này, hãy nhập một mô hình tham khảo Lola vào dự án mẫu mannequin.

Để nhập mô hình của bạn:

  1. Trong Blender, điều hướng đến File > Open và chọn Rig_and_Attachments_Template.blend.

  2. Điều hướng đến File > Import > FBX (.fbx) và nhập tệp mô hình tham khảo Lola.

  3. Nếu cần, hãy điều chỉnh kích thước mô hình để phù hợp với kích thước của cấu trúc xương armature. Bạn có thể chọn tất cả các hình học lưới trong Outliner và nhấn G để định vị lại và S để thay đổi kích thước các đối tượng lưới bằng cách kéo chuột của bạn.

Hình ảnh xem

Để có hình ảnh tốt hơn và truy cập vào các đối tượng xương của bạn, hãy thiết lập các đối tượng xương của bạn luôn hiển thị ở phía trước của Viewport.

Để thiết lập hình ảnh xương:

  1. Trong Viewport, nhấp vào bất kỳ xương nào trong armature của bạn.
  2. Trong bảng Properties Editor, chọn tab Object Data Properties.
  3. Mở rộng Viewport Display, điều hướng đến thuộc tính Show, sau đó bật In Front.

Bất kỳ lúc nào trong quá trình skin, bạn cũng có thể chuyển đổi một trong các tùy chọn xem vật liệu khác nhau ở góc trên bên phải của Viewport 3D của bạn để thay đổi hình ảnh của mô hình nhân vật của bạn, chẳng hạn như bật chế độ X-ray hoặc chế độ xem kết cấu.

Thiết lập xương và armature

Trong hướng dẫn này, hãy thiết lập X-Axis Mirroring để thực hiện các thay đổi đối xứng cho các xương bên trái và bên phải trước khi định vị lại các xương cho mô hình đã nhập. Cố gắng duy trì sự đối xứng bất cứ khi nào có thể khi rig một mô hình.

Bật gương trục x

Cài đặt Gương Trục X cho phép bạn duy trì sự đối xứng với các xương bên trái và bên phải của bạn bằng cách phản chiếu các thay đổi về vị trí của chúng. Để giảm thiểu các vấn đề với việc tạo dáng và hoạt hình, điều quan trọng là giữ sự đối xứng với cấu trúc xương của bạn bất cứ khi nào có thể.

Để thiết lập Gương Trục X:

  1. Trong Object Mode, chọn armature của bạn bằng cách nhấp vào bất kỳ xương nào.

  2. Chuyển sang Edit Mode (Tab).

  3. Trong thanh bên phải của Viewport, mở rộng bảng Công cụ và bật X-Axis Mirror.

Định vị xương

Với mô hình đã được thêm vào dự án, bạn có thể định vị lại các xương được cung cấp trong mẫu để phù hợp với cấu trúc nhân vật. Trong hầu hết các trường hợp, mỗi xương nên được định vị ở trung tâm của các đối tượng lưới tương ứng của chúng, chẳng hạn như xương Đầu được đặt ở trung tâm của đối tượng lưới Head_Geo.

Việc định vị xương có thể khác nhau tùy thuộc vào trường hợp sử dụng và có thể cần được xem xét lại sau khi sơn trọng số và thử nghiệm nếu một tư thế hoặc hoạt hình nhất định không hoạt động như mong muốn.

Để định vị các xương riêng lẻ của bạn:

  1. Trong Object Mode, nhấp vào xương mà bạn muốn định vị lại để làm nổi bật nó.

  2. Từ menu thả xuống Chế độ, chuyển sang Edit Mode.

  3. Nhấp vào đầu của xương để đầu được làm nổi bật và nhấn G. Đỉnh của xương sẽ di chuyển theo con trỏ của bạn.

  4. Kéo xương này để căn chỉnh với trung tâm bên trong của mô hình, sau đó nhấp để đặt vị trí của xương.

  5. Nhấp và giữ bánh xe cuộn chuột của bạn hoặc sử dụng một trong các chế độ xem khác nhau để xác minh rằng xương nằm trong đối tượng lưới.

Làm cha armature

Sau khi bạn định vị cấu trúc xương, bạn cần làm cha armature xương với mô hình. Bạn phải làm cha tất cả 15 đối tượng lưới với một armature.

Trong ví dụ này, các đối tượng lưới được làm cha với Armature bằng các Nhóm Trống để minh họa quy trình gán nhóm đỉnh và sơn trọng số trong hướng dẫn tiếp theo Skin một mô hình người.

Để làm cha mô hình với armature:

  1. Chuyển sang Object Mode.

  2. Trong Outliner, lọc các đối tượng lưới của bạn bằng cách gõ "geo" vào thanh tìm kiếm.

  3. Chọn tất cả các đối tượng lưới trong Outliner bằng cách giữ Shift và nhấp vào đối tượng lưới đầu tiên và cuối cùng.

  4. Với các lưới được làm nổi bật, giữ Shift và nhấp vào đối tượng Armature trong Viewport hoặc Outliner.

  5. Nhấp chuột phải trong Viewport và chọn Parent > With Empty Groups.

Gán lưới cho xương

Bây giờ bạn đã kết nối armature của mình với đối tượng lưới, bạn có thể gán các đỉnh của các chi riêng lẻ của bạn để được ảnh hưởng hoàn toàn bởi một xương tương ứng. Sau khi quy trình này hoàn tất, mô hình sẽ sẵn sàng để skin. Xem Skin một mô hình người để biết hướng dẫn về việc áp dụng nhiều ảnh hưởng xương cho một lưới.

Để gán ảnh hưởng đầy đủ cho đối tượng lưới đầu:

  1. Trong Object Mode, nhấp vào đối tượng lưới đầu để làm nổi bật nó.

  2. Chuyển sang Edit Mode.

  3. Chọn tất cả các đỉnh của đối tượng lưới của bạn bằng cách nhấn A.

  4. Sau khi tất cả các đỉnh đầu được làm nổi bật, điều hướng đến bảng Object Properties ở bên phải màn hình.

  5. Trong phần Vertex Group của bảng, chọn tên của xương mà bạn muốn gán hình học Đầu và nhấp Assign.

Bạn có thể nhanh chóng lặp lại tất cả các đối tượng lưới của bạn trong chế độ này bằng cách chọn đối tượng lưới tiếp theo trong Outliner và gán nó vào Nhóm Đỉnh thích hợp. Đối với hướng dẫn này, gán tất cả các đối tượng lưới của nhân vật của bạn vào xương tương ứng của chúng.

Để nhanh chóng gán các nhóm đỉnh cho các lưới còn lại của cơ thể:

  1. Trong bảng Outliner, nhấp vào chấm bên cạnh đối tượng mà bạn định chỉnh sửa. Chấm sẽ chuyển sang biểu tượng chỉnh sửa hoạt động khi được nhấn.

  2. Nếu các đỉnh không được làm nổi bật, nhấn A để chọn tất cả các đỉnh.

  3. Trong bảng Object Properties > phần Vertex Groups, chọn nhóm đỉnh thích hợp và nhấp Assign. Bạn có thể sử dụng thanh tìm kiếm để tìm tên nhóm đỉnh cụ thể.

Kiểm tra

Bạn có thể kiểm tra và tạo dáng cho các xương và các đối tượng lưới được gán của chúng trong Pose Mode. Điều quan trọng là kiểm tra mô hình của bạn sau khi áp dụng hoặc chỉnh sửa bất kỳ ảnh hưởng nào.

Để điều hướng đến chế độ Pose và kiểm tra các tư thế của bạn:

  1. Trong Object Mode, chọn bất kỳ phần nào của mô hình của bạn.

  2. Nhấp vào menu thả xuống Chế độ, sau đó chuyển sang chế độ Pose.

  3. Giữ Shift và nhấp vào xương mà bạn muốn kiểm tra để làm nổi bật nó, sau đó nhấn R để kiểm tra độ xoay.

  4. Nhấn AltA (A) để bỏ chọn xương hiện tại, sau đó chọn lại và kiểm tra một xương khác.

Tại giai đoạn này, nếu tất cả các đối tượng lưới của bạn đều bị ảnh hưởng bởi các xương tương ứng của chúng, bạn có thể xuất mô hình đã rig này dưới dạng .fbx để sử dụng trong Studio hoặc tiếp tục đến giai đoạn tiếp theo của Skin một mô hình người.

©2026 Roblox Corporation. Roblox, logo Roblox và Powering Imagination là các nhãn hiệu đã đăng ký và chưa đăng ký của chúng tôi tại Hoa Kỳ và các quốc gia khác.