Editor del Terreno

*Questo contenuto è tradotto usando AI (Beta) e potrebbe contenere errori. Per visualizzare questa pagina in inglese, clicca qui.

L'Editor del Terreno, accessibile dalla scheda Home di Studio o dal menu Finestra ⟩ 3D, ti consente di generare e manipolare terreno ambientale attraverso i suoi strumenti Crea e Modifica.

Editor del Terreno indicato nella barra degli strumenti di Studio

Scheda Crea

La scheda Crea include gli strumenti Importa, Genera e Pulisci.

Importa

Lo strumento Importa importa una mappa di altezza e una mappa di colori opzionale e le applica a una regione selezionata.

Strumento Importa indicato nella scheda Crea dell'Editor del Terreno
Esempio di immagine della mappa di altezza
Mappa di altezza
Esempio di immagine della mappa di colori
Mappa di colori
Terreno generato dalla mappa di altezza e dalla mappa di colori di esempio
Terreno generato
Impostazioni di selezione
Opzioni di dimensione, posizione e aggancio come descritto per lo strumento Seleziona.
Impostazioni della mappa di altezza
Mappa di altezzaImporta una mappa di altezza da un file immagine locale.
Mappa di coloriImporta una mappa di colori da un file immagine locale da utilizzare insieme a una mappa di altezza.
Materiale predefinitoSpecifica un materiale consistente da applicare su tutto il terreno generato. Questo viene sovrascritto dai materiali basati sulla mappa di colori, se importata.

Genera

Lo strumento Genera genera proceduralmente terreno all'interno di una regione selezionata. Questo è utile se desideri creare una mappa grande e poi perfezionare i dettagli del terreno utilizzando gli strumenti della scheda Modifica.

Strumento Genera indicato nella scheda Crea dell'Editor del Terreno
Impostazioni di selezione
Opzioni di dimensione, posizione e aggancio come descritto per lo strumento Seleziona.
Impostazioni del bioma
BiomiInclude i biomi selezionati nel terreno generato.
MiscelazioneRegola come i biomi si mescolano tra loro, con valori più alti un po' più morbidi.
GrotteInclude grotte nel terreno generato.
Dimensione del biomaImposta la dimensione dei biomi all'interno della dimensione complessiva del terreno.
SeedUn numero che Studio genera per determinare la forma del terreno. Quando cambi questo numero, Studio genera un nuovo terreno con le stesse impostazioni.

Pulisci

Lo strumento Pulisci rivela un pulsante che pulisce tutto il terreno all'interno dell'intero luogo.

Strumento Pulisci indicato nella scheda Crea dell'Editor del Terreno

Scheda Modifica

La scheda Modifica include gli strumenti Seleziona, Trasforma, Riempi, Livello del mare, Disegna, Scolpisci, Liscia, Pittura e Appiattisci.

Seleziona

Lo strumento Seleziona è uno strumento universale per selezionare regioni rettangolari di terreno. Con lo strumento abilitato, seleziona una regione facendo clic e trascinando nella vista 3D, riposizionala con i dragger di movimento e modifica la sua dimensione con le maniglie di scala. In alternativa, inserisci valori negli input X/Y/Z dello strumento per impostare una posizione e una dimensione specifiche.

Strumento Seleziona indicato nella scheda Modifica dell'Editor del Terreno
Impostazioni di selezione
DimensioneImposta valori specifici X/Y/Z per la dimensione della selezione, in stud.
PosizioneImposta valori specifici X/Y/Z per la posizione della selezione.
Aggancia ai VoxelsAggancia i limiti di selezione al voxel più vicino.
Draggers di movimento e maniglie di scala su una regione selezionata
Draggers di movimento e maniglie di scala su una regione selezionata

Studio supporta anche le seguenti scorciatoie da tastiera e mouse, a condizione che lo strumento Seleziona sia attivo e nulla sia selezionato nella gerarchia Esplora.

WindowsMacAzioni
CtrlC⌘CCopia il terreno all'interno della regione selezionata negli appunti.
CtrlV⌘VIncolla il terreno che è stato copiato negli appunti e passa allo strumento Trasforma in modo che il nuovo terreno possa essere trasformato.
CtrlX⌘XTaglia il terreno all'interno della regione selezionata negli appunti.
CtrlD⌘DDuplica il terreno all'interno della regione selezionata e passa allo strumento Trasforma in modo che il nuovo terreno possa essere trasformato.
DeleteDeleteElimina il terreno all'interno della regione selezionata.
ShiftShiftQuando tenuto premuto mentre si trascina qualsiasi maniglia di scala, scala la regione proporzionalmente su tutti gli altri assi.
Ctrl⌘Quando tenuto premuto mentre si trascina qualsiasi maniglia di scala, scala la regione in modo uniforme sia in direzione positiva che negativa lungo quell'asse.

Trasforma

Lo strumento Trasforma manipola intere regioni selezionate a una nuova posizione, dimensione o orientamento. Con lo strumento abilitato, trasforma una regione selezionata con i dragger di movimento, gli anelli di rotazione e le maniglie di scala. In alternativa, inserisci valori negli input X/Y/Z dello strumento per impostare una posizione, dimensione e rotazione specifiche.

Strumento Trasforma indicato nella scheda Modifica dell'Editor del Terreno
Impostazioni di trasformazione
DimensioneImposta valori specifici X/Y/Z per la dimensione della selezione in stud.
PosizioneImposta valori specifici X/Y/Z per la posizione della selezione.
RotazioneImposta valori specifici X/Y/Z per la rotazione della selezione in gradi.
Unisci vuotiQuando abilitato, i voxel d'aria nella selezione sovrascriveranno i voxel esistenti nella destinazione.
Modifica dal vivoQuando abilitato, il terreno viene costantemente aggiornato mentre viene trasformato. Per visualizzare solo un'anteprima wireframe della trasformazione, disabilita la modalità di modifica dal vivo e poi, mentre trasformi, premi Enter/Return o fai clic sul pulsante Applica per applicare le modifiche.
Aggancia ai VoxelsAggancia i limiti di selezione al voxel più vicino.
Draggers di movimento, anelli di rotazione e maniglie di scala su una regione selezionata
Draggers di movimento, anelli di rotazione e maniglie di scala su una regione selezionata

Riempi

Lo strumento Riempi riempie un'intera regione selezionata con un materiale specifico, o sostituisce tutto il materiale all'interno della regione con un altro materiale.

Strumento Riempi indicato nella scheda Modifica dell'Editor del Terreno
Impostazioni di selezione
Opzioni di dimensione, posizione e aggancio come descritto per lo strumento Seleziona.
Impostazioni del materiale
Modalità di riempimentoAttiva la modalità Riempi e Sostituisci dello strumento.
Materiale sorgenteIn modalità Riempi, il materiale di riempimento desiderato. In modalità Sostituisci, il materiale da sostituire.
Materiale targetIn modalità Sostituisci, il materiale con cui sostituire il materiale sorgente.
Regione riempita con materiale Sale
Regione selezionata riempita con materiale Sale

Livello del mare

Lo strumento Livello del mare ti consente di creare un livello d'acqua consistente o rimuovere tutta l'acqua all'interno di una regione.

Strumento Livello del mare indicato nella scheda Modifica dell'Editor del Terreno
Impostazioni del livello del mare
DimensioneImposta valori specifici X/Y/Z per la dimensione della selezione in stud.
PosizioneImposta valori specifici X/Y/Z per la posizione della selezione.
Aggancia ai VoxelsAggancia i limiti di selezione al voxel più vicino.

Disegna

Lo strumento Disegna aggiunge o sottrae terreno utilizzando il pennello. Questo strumento funziona in una modalità duale in cui tenere premuto Ctrl o ⌘ attiva la modalità "sottrai" invece della modalità "aggiungi" predefinita. Inoltre, tenere premuto Shift attiva temporaneamente lo strumento Liscia.

Strumento Disegna indicato nella scheda Modifica dell'Editor del Terreno
Impostazioni del pennello
Modalità pennelloAttiva la modalità Aggiungi e Sottrai dello strumento. Attivata anche tenendo premuto Ctrl o ⌘.
Forma del pennelloImposta la forma del pennello su sfera, scatola o cilindro.
Icone della forma del pennello nell'Editor del Terreno
Dimensione del pennelloImposta la dimensione del pennello da 1 a 64. Se scegli una forma del pennello di scatola o cilindro, appare anche un cursore/input di Altezza per regolare l'altezza del pennello proporzionalmente o indipendentemente dalla dimensione di base.
Posizione del pivotImposta il punto di pivot verticale del pennello sul fondo, centro o cima di dove il pennello si collega con il terreno esistente.
AggancioSe l'aggancio è disattivato o al voxel più vicino.
Blocco del pianoAttiva o disattiva un piano visivo a cui il pennello si blocca. In modalità Auto, il piano si inclina e ruota con la telecamera. In modalità Manuale, appare l'opzione Modifica Piano, consentendoti di impostare una posizione/orientamento specifico tramite i dragger visivi o gli input X/Y/Z.
Ignora acquaIgnora l'acqua quando aggiungi o sottrai terreno.
Ignora partiIgnora parti riguardo al posizionamento del pennello mentre muovi il puntatore del mouse sulle superfici delle parti.
Impostazioni del materiale
Materiale automaticoUtilizza lo stesso materiale del terreno nelle vicinanze del pennello quando aggiungi nuovo terreno.
Materiale sorgenteImposta il materiale per la modalità Aggiungi.

Scolpisci

Lo strumento Scolpisci aggiunge o sottrae terreno utilizzando il pennello. A differenza dello strumento Disegna, questo strumento include un cursore/input di forza per consentire una manipolazione più delicata del terreno. Questo strumento funziona in una modalità duale in cui tenere premuto Ctrl o ⌘ attiva la modalità "sottrai" invece della modalità "aggiungi" predefinita, e tenere premuto Shift attiva temporaneamente lo strumento Liscia.

Strumento Scolpisci indicato nella scheda Modifica dell'Editor del Terreno
OpzioneDescrizione
Modalità pennelloAttiva la modalità Aggiungi e Sottrai dello strumento. Attivata anche tenendo premuto Ctrl o ⌘.
Forma del pennelloImposta la forma del pennello su sfera, scatola o cilindro.
Icone della forma del pennello nell'Editor del Terreno
Dimensione del pennelloImposta la dimensione del pennello da 1 a 64. Se scegli una forma del pennello di scatola o cilindro, appare anche un cursore/input di Altezza per regolare l'altezza del pennello proporzionalmente o indipendentemente dalla dimensione di base.
ForzaImposta la forza del pennello da 0.1 a 1.
Blocco del pianoAttiva o disattiva un piano visivo a cui il pennello si blocca. In modalità Auto, il piano si inclina e ruota con la telecamera. In modalità Manuale, appare l'opzione Modifica Piano, consentendoti di impostare una posizione/orientamento specifico tramite i dragger visivi o gli input X/Y/Z.
Ignora acquaIgnora l'acqua quando aggiungi o sottrai terreno.
Ignora partiIgnora parti riguardo al posizionamento del pennello mentre muovi il puntatore del mouse sulle superfici delle parti.
Materiale automaticoUtilizza lo stesso materiale del terreno nelle vicinanze del pennello quando aggiungi nuovo terreno.
Materiale sorgenteImposta il materiale per la modalità Aggiungi.

Liscia

Lo strumento Liscia leviga i bordi bruschi nel terreno utilizzando il pennello. Questo strumento può essere utilizzato in modalità autonoma, oppure puoi attivarlo tenendo premuto Shift mentre utilizzi gli strumenti Disegna o Scolpisci.

Strumento Liscia indicato nella scheda Modifica dell'Editor del Terreno
OpzioneDescrizione
Forma del pennelloImposta la forma del pennello su sfera, scatola o cilindro.
Icone della forma del pennello nell'Editor del Terreno
Dimensione del pennelloImposta la dimensione del pennello da 1 a 64. Se scegli una forma del pennello di scatola o cilindro, appare anche un cursore/input di Altezza per regolare l'altezza del pennello proporzionalmente o indipendentemente dalla dimensione di base.
ForzaImposta la forza del pennello da 0.1 a 1.
Posizione del pivotImposta il punto di pivot verticale del pennello sul fondo, centro o cima di dove il pennello si collega con il terreno esistente.
AggancioSe l'aggancio è disattivato o al voxel più vicino.
Blocco del pianoAttiva o disattiva un piano visivo a cui il pennello si blocca. In modalità Auto, il piano si inclina e ruota con la telecamera. In modalità Manuale, appare l'opzione Modifica Piano, consentendoti di impostare una posizione/orientamento specifico tramite i dragger visivi o gli input X/Y/Z.
Ignora acquaIgnora l'acqua quando lisci il terreno.
Ignora partiIgnora parti riguardo al posizionamento del pennello mentre muovi il puntatore del mouse sulle superfici delle parti.

Pittura

Lo strumento Pittura, utilizzando il pennello, pitturare un materiale del terreno su un materiale esistente o sostituisce un materiale con un altro materiale.

Strumento Pittura indicato nella scheda Modifica dell'Editor del Terreno
OpzioneDescrizione
Forma del pennelloImposta la forma del pennello su sfera, scatola o cilindro.
Icone della forma del pennello nell'Editor del Terreno
Dimensione del pennelloImposta la dimensione del pennello da 1 a 64. Se scegli una forma del pennello di scatola o cilindro, appare anche un cursore/input di Altezza per regolare l'altezza del pennello proporzionalmente o indipendentemente dalla dimensione di base.
Posizione del pivotImposta il punto di pivot verticale del pennello sul fondo, centro o cima di dove il pennello si collega con il terreno esistente.
AggancioSe l'aggancio è disattivato o al voxel più vicino.
Blocco del pianoAttiva o disattiva un piano visivo a cui il pennello si blocca. In modalità Auto, il piano si inclina e ruota con la telecamera. In modalità Manuale, appare l'opzione Modifica Piano, consentendoti di impostare una posizione/orientamento specifico tramite i dragger visivi o gli input X/Y/Z.
Ignora acquaIgnora l'acqua quando appiattisci il terreno.
Ignora partiIgnora parti riguardo al posizionamento del pennello mentre muovi il puntatore del mouse sulle superfici delle parti.
Modalità materialeAttiva la modalità Pittura e Sostituisci dello strumento. In modalità Pittura, scegli il materiale di pittura desiderato dai riquadri del selettore dello strumento. In modalità Sostituisci, scegli sia il materiale sorgente da sostituire che il materiale target con cui sostituirlo.

Appiattisci

Lo strumento Appiattisci appiattisce il terreno a un livello consistente attraverso un piano visualizzato. Per impostazione predefinita, lo strumento abbassa il terreno sopra il piano e solleva il terreno sotto il piano, ma puoi scegliere di abbassare o sollevare selettivamente tramite l'opzione Modalità Appiattisci dello strumento.

Strumento Appiattisci indicato nella scheda Modifica dell'Editor del Terreno
OpzioneDescrizione
Forma del pennelloImposta la forma del pennello su sfera, scatola o cilindro.
Icone della forma del pennello nell'Editor del Terreno
Modalità AppiattisciErosione a Piatto¹ appiattisce il terreno sopra il piano. Crescita a Piatto² riempie il terreno sotto il piano. Appiattisci Tutto³ rimuove il terreno sopra il piano e riempie il terreno sotto il piano.
Icone della Modalità Appiattisci nell'Editor del Terreno
Dimensione del pennelloImposta la dimensione del pennello da 1 a 64. Se scegli una forma del pennello di scatola o cilindro, appare anche un cursore/input di Altezza per regolare l'altezza del pennello proporzionalmente o indipendentemente dalla dimensione di base.
ForzaImposta la forza del pennello da 0.1 a 1.
Posizione del pivotImposta il punto di pivot verticale del pennello sul fondo, centro o cima di dove il pennello si collega con il terreno esistente.
AggancioSe l'aggancio è disattivato o al voxel più vicino.
Piano di AppiattimentoSe impostato su Fisso, appiattisce il terreno a un piano visivo fisso nello spazio mondiale Y.
Ignora acquaIgnora l'acqua quando appiattisci il terreno.
Ignora partiIgnora parti riguardo al posizionamento del pennello mentre muovi il puntatore del mouse sulle superfici delle parti.

Scorciatoie di Studio

Per gli strumenti che utilizzano il pennello (Disegna, Scolpisci, Liscia, Appiattisci, Pittura), Studio supporta le seguenti scorciatoie da tastiera e mouse.

WindowsMacAzioni
Ctrl⌘Quando tenuto premuto mentre si utilizzano gli strumenti Disegna e Scolpisci, attiva la modalità pennello alternativa. Ad esempio, attiva la modalità "sottrai" invece della modalità "aggiungi" predefinita.
ShiftShiftQuando tenuto premuto mentre si utilizzano gli strumenti Disegna e Scolpisci, attiva temporaneamente lo strumento Liscia.
BBQuando tenuto premuto mentre si trascina il mouse o si utilizza la rotella di scorrimento, regola la dimensione di base del pennello.
CtrlB⌘BQuando tenuto premuto mentre si trascina il mouse o si utilizza la rotella di scorrimento, regola l'altezza del pennello. Si applica solo se la forma del pennello è impostata su scatola o cilindro.
ShiftBShiftBQuando tenuto premuto mentre si trascina il mouse o si utilizza la rotella di scorrimento, regola la forza del pennello. Si applica solo quando si utilizza lo strumento Scolpisci, Liscia o Appiattisci.
Alt⌥Quando tenuto premuto durante il clic del mouse, mostra il selettore di materiali.
© 2026 Roblox Corporation. Roblox, il logo Roblox e Powering Imagination sono tra i nostri marchi registrati e non registrati negli Stati Uniti. e altri paesi.