Dynamische hoofden zijn karakterhoofden die componenten bevatten waarmee je:
- Standaard aangepaste gezichtsuitdrukkingen kunt instellen.
- Gezichtsaccessoires kunt uitrusten, zoals wenkbrauwen en wimpers, die vervormen met je gezichtsuitdrukkingen.
- Emoties kunt activeren die zowel gezichts- als lichaamsanimaties combineren.
Je kunt een bestaand model maken of aanpassen om een dynamisch hoofd te worden in externe modelleringsoftware, zoals Blender of Maya. Bij het maken van een dynamisch hoofd moet je ervoor zorgen dat je karakterlichaamsmodel aan de volgende vereisten voldoet:
- Het karakterlichaam moet voldoen aan de modelleringseisen van Roblox en moet geschikte hoofdgeometrie bevatten, zoals ogen, een mond en tanden.
- Het hoofd van het karakterlichaam moet een rig of interne gewrichtstructuur bevatten om de verschillende vervormingen van de vertices aan te sturen om gezichtsuitdrukkingen te creëren.
- Het karakterlichaam moet hun gezichtsposes opgeslagen hebben in de animatietijdlijn en gemapt zijn op het hoofdmesh. Typische dynamische hoofden bevatten 50 standaard basisposes die een breed scala aan uitdrukkingen mogelijk maken.
Om je te helpen aan deze vereisten te voldoen, behandelt deze tutorial de processen van het toevoegen van gezichtsgewrichten, het poseren ervan in gezichtsuitdrukkingen en het mappen van 5 basis FACS-poses op een Cubie-referentiekarakter in Blender, evenals hoe je het model kunt exporteren voor import in Studio.
Referentiebestanden
De volgende referentiebestanden voor dynamische hoofden bevatten alle controlepunten door deze tutorial:
| Referentiebestanden | Beschrijving |
|---|---|
| Cubie-Model-Only.blend | Een Blender-projectbestand met een Cubie-karaktermodel met een standaard R15 rig zonder gezichtsdata. |
| Cubie-Eye-Bones-Skinned.blend | Een Blender-projectbestand met het voorbeeld Cubie-karaktermodel met geskinte ooggewrichten zonder pose- of mappingdata. |
| Cubie-Eye-Poses-Mapped.blend | Een Blender-projectbestand met het Cubie-karaktermodel met de 5 voorbeeldposes opgeslagen en gemapt. |
| Cubie-Complete.fbx | Een Cubie-karaktermodel met een volledig gerigged gezicht en meer dan 50 opgeslagen en gemapte poses. Je kunt dit bestand importeren in Studio of openen in je favoriete 3D-modelleringssoftware. |
| Cubie-Texture_ALB.png | Een Cubie-textuurafbeeldingsbestand. Nadat je het Cubie-model in Studio hebt geïmporteerd, kun je dit bestand toevoegen als de TextureID van het hoofdonderdeel. |
| Cubie-Complete.ma | Een Cubie Maya-project dat als aanvullende referentie wordt verstrekt. |
Modelleringseisen
Veel karakterlichaamsmodellen die een hoofd met duidelijke gelaatskenmerken bevatten, vereisen kleine modelleringaanpassingen om compatibel te zijn als een dynamisch hoofd. Wanneer je je avatar-karakters modelleert, controleer dan of elk hoofdmesh voldoet aan de avatar lichaamspecificaties voor Studio-import, evenals de volgende vereisten:
- Gezichtsonderdelen - Zorg ervoor dat je duidelijke gelaatskenmerken opneemt, zoals ogen, bovenste tanden, onderste tanden en een tong.
- Lipvertices - Als je wilt dat je karakter zijn mond gebruikt, scheid dan de lipvertices zodat de mond kan openen.
- Interne componenten - Als je karakter interne mondcomponenten heeft, zoals een tong en tanden, modelleer dan een mondzak binnen het hoofdmesh om deze kenmerken te bevatten. Als je karakter oogkassen gebruikt, modelleer dan een vergelijkbare oogzak om deze kenmerken te bevatten.
- Geen extra data - Zorg ervoor dat alle kindergezichtsonderdelen van de Head_Geo geen geschiedenis of bevroren transformaties bevatten.
- Buitenste kooi - Zorg ervoor dat het karaktermodel een buitenste kooi heeft om gezichtsaccessoires en gelaagde accessoires te ondersteunen. Voor meer informatie, zie Lichaamspecificaties - Binnenste en buitenste kooien.
Je kunt de rest van dit proces voor het maken van een hoofd volgen met een gerigged Cubie-karakter dat aan deze modelleringseisen voldoet. Deze versie bevat geen gezichtsrigging of posedata, zodat je het als startpunt voor deze tutorial kunt gebruiken.
Rig en skin het hoofd
Rigging is het proces van het verbinden van een mesh met een interne rig, zodat de meshoppervlakken kunnen draaien en bewegen terwijl de gewrichten draaien en bewegen, en skinning is het proces van het toewijzen van welke delen van het meshoppervlak bewegen en draaien met specifieke gewrichten. Dynamische hoofden vereisen beide processen, zodat de oppervlakken van het hoofdmesh kunnen bewegen met gewrichten om gezichtsuitdrukkingen te creëren.
De volgende instructies richten zich op het riggen en skinen van Cubie's ogen en oogleden, maar je kunt deze technieken toepassen op de rest van de gezichtskenmerken van het karakter die articulatie vereisen, zoals de mond, wangen en kaak van het karakter. Nadat je gewrichten hebt toegevoegd en skindata hebt toegepast, kun je vervolgens controles maken om het poseren efficiënter te maken.
Voeg gewrichten toe
Elke poseerbare gezichtskenmerk van je hoofd vereist doorgaans minstens één gewricht, maar complexe kenmerken, zoals ogen en mond, kunnen meerdere gewrichten vereisen om bepaalde poses mogelijk te maken. In tegenstelling tot de rest van het lichaam van het karakter, vereist Studio geen specifieke gewrichthiërarchie voor een dynamisch hoofd. Om ervoor te zorgen dat de gezichtsrig goed werkt, moet de rig echter een RootFaceJoint-gewricht en aanvullende gezichtsgewrichten bevatten om de buiging en vervorming van de gezichtgeometrie aan te sturen.
De specifieke hoofdgewrichten die je karakter nodig heeft, zijn afhankelijk van de poses die je voor je karakter bedoelt. De volgende voorbeelden behandelen het proces voor het toevoegen van 1 gewricht voor elk oog en 4 gewrichten voor de oogleden om knipperen, knipogen en kijkrichting mogelijk te maken. Bij het maken van een gezichtsrig, gebruik je waar mogelijk minder dan 50 gezichtsgewrichten en houd je de gewrichten georganiseerd en specifiek voor hun bijbehorende gezichtskenmerken. Over het algemeen kunnen hoge aantallen vertices en gewrichten de prestaties van je game beïnvloeden.
RootFaceJoint
De RootFaceJoint is een gewricht dat onder het hoofdgewricht van de R15 rigging armature is geparent. Dit rootgewricht moet alle andere gezichtsgewrichten parenten. In Blender kun je snel een gewricht toevoegen door een kindgewricht uit het hoofdgewricht te extruderen, en vervolgens de gewrichtnaam als een eigenschap in het Head_Geo-mesh te mappen.
Het RootFaceJoint-object wordt vaak DynamicHead genoemd in de referentietemplates en voorbeelden, maar je kunt elke naam gebruiken zolang je de rootjoint mapt in aangepaste eigenschappen. Dit stelt Studio in staat om dat gewricht correct te lokaliseren en alle kindergewrichten binnen de FaceControls-instantie te verbergen bij import.
Om een RootFaceJoint-object toe te voegen:
Open in Blender het gerigged Cubie karakter project.

Klik op een gewricht om de armature te selecteren, schakel vervolgens over naar de Bewerken-modus.
Klik in de Outliner op het Hoofd-gewricht.
Druk in de viewport op E en sleep je muis omhoog om een extra kindgewricht uit het Hoofd-gewricht te extruderen.
Terug in de Outliner, hernoem dit gewricht naar DynamicHead. Je zult dit gewricht later bij naam verwijzen in de mapping sectie.
Ogen
Elk oog vereist één gewricht, hoewel je ervoor kunt kiezen om later een controllergewricht te maken dat beide ogen tegelijk kan aansturen. Om ervoor te zorgen dat je gewrichten symmetrisch zijn gepositioneerd, kun je X-Axis-symmetrie inschakelen in de rechterbovenhoek van de viewport. Dit verplaatst gewrichten die dezelfde naam delen met tegenhanger-suffixen langs de X-as.
Om gewrichten aan de ogen van het karakter toe te voegen:
Terwijl je nog in de Bewerken-modus bent, navigeer je naar de bovenbalk van de viewport, klik dan op Toevoegen > Enkel Gewricht. Doe dit twee keer.
Hernoem één gewricht naar LeftEye en het andere naar RightEye.
Pas de gewrichten aan zodat ze naar voren gericht, horizontaal en rond de iris van de ogen van het karakter zijn:
- Schakel in de rechterbovenhoek van de viewport X-Axis-symmetrie in.
- Gebruik de Verplaatsen-tool om het linker- of rechtergewricht in het midden van de ogen van het model te positioneren.
- Breid het Item-paneel uit, en met de gewrichten geselecteerd:
- Kopieer de Hoofd Y-locatie naar de Staart Y-locatie.
- Stel Staart Z in op 0.2 centimeter om de Staart Z-coördinaten met een offset van 0.2 centimeter van de Hoofd Z-coördinaten in te stellen.
Parent de nieuwe gewrichten aan je RootFaceJoint.
- Houd Shift ingedrukt en klik op zowel de LeftEye als de RightEye gewrichten.
- Terwijl je Shift nog steeds ingedrukt houdt, klik op het DynamicHead-gewricht.
- Klik met de rechtermuisknop in de viewport en selecteer Parent > Make > With Offset in het contextmenu.
Oogleden
Bij het toevoegen van gewrichten kun je snel gewrichten maken die onder het RootFaceJoint-gewricht zijn geparent door bestaande gezichtsgewrichten te selecteren en te dupliceren. Dit maakt automatisch gewrichten die onder het RootFaceJoint-gewricht zijn geparent.
Om gewrichten aan de oogleden van het karakter toe te voegen:
Terwijl je nog in de Bewerken-modus bent, houd Shift ingedrukt en klik op zowel de LeftEye als de RightEye gewrichten.
Houd Shift + D ingedrukt en klik om de gewrichten in dezelfde positie te dupliceren. Doe dit vier keer om in totaal 8 nieuwe gewrichten te maken.
Met X-Axis-symmetrie nog steeds ingeschakeld, positioneer je elk gewricht in de hoeken van de ogen.
Hernoem in de Outliner alle gewrichten om hun specifieke positie weer te geven met de volgende namen:
- LeftUpperOuterEyelid
- RightUpperOuterEyelid
- LeftLowerOuterEyelid
- RightLowerOuterEyelid
- LeftUpperInnerEyelid
- RightUpperInnerEyelid
- LeftLowerInnerEyelid
- RightLowerInnerEyelid

Skin gewrichten
Je kunt skindata toepassen op een karakterrig met verschillende methoden. Het volgende voorbeeld gebruikt Blender's Weight Paint-modus om te schilderen welke vertices een enkel gewricht kan aansturen. Skinning is doorgaans een tijdrovende stap voor complexe karakters en een achtergrond in skinning en gezichtsposeren wordt aanbevolen.
Bij het toepassen van gedetailleerde of gedeelde invloeden voor complexe modellen, is het aan te raden om Auto Normalize in te schakelen om invloedconflicten tussen gewrichten te voorkomen.
Ogen
Beide ogen in het voorbeeldproject vereisen volledige invloeden op de pupil binnen de ooggeometrie. Afhankelijk van het ontwerp van de ogen, moet je mogelijk invloeden aanpassen om realistische oogposes te creëren.
Om invloed aan je ooggewrichten toe te voegen:
Schakel X-Axis-symmetrie uit zodat je alleen de LeftEye-gewricht beïnvloedt.
Schakel over naar de Object-modus, klik op een gewricht om de armature te selecteren, houd vervolgens Shift ingedrukt en klik op het Head_Geo-mesh.
Schakel over naar de Weight Paint-modus, schakel vervolgens in de rechterbovenhoek van de viewport Wireframe-modus in om de vertices beter te visualiseren.
Houd Shift + Ctrl ingedrukt en klik op het LeftEye-gewricht om het te selecteren. De naam van het momenteel geselecteerde gewricht wordt linksboven in de viewport weergegeven.
Schilder invloed op de vertices binnen het oog. Zorg ervoor dat de pupillen rood zijn, of volledig beïnvloed door het geselecteerde gewricht.
Schakel over naar de Object-modus, schakel Viewport Shading in om het mesh beter te visualiseren, klik vervolgens op een gewricht om de armature te selecteren.
Schakel over naar de Pose-modus en test de invloeden van het ooggewricht door het gewricht vast te pakken en te verplaatsen. Het mesh volgt op de juiste manier.
Herhaal deze stappen voor het RightEye-gewricht.
Oogleden
Ooglidgewrichten vereisen hun eigen aparte invloeden. Terwijl de voorbeeldposes alleen de bovenste oogleden manipuleren, is het belangrijk om de onderste hoeken van de oogleden te kunnen aansturen voor andere poses, zoals LeftCheekRaiser en RightCheekRaiser.
Om invloed aan de ooglidgewrichten toe te voegen:
Schakel over naar de Object-modus, klik op een gewricht om de armature te selecteren, houd vervolgens Shift ingedrukt en klik op het Head_Geo-mesh.
Schakel over naar de Weight Paint-modus, schakel vervolgens in de rechterbovenhoek van de viewport Wireframe-modus in om de vertices beter te visualiseren.
Houd Shift + Ctrl ingedrukt en klik op het LeftUpperOuterEyelid-gewricht om het te selecteren.
Schilder indien nodig invloeden op de dichtstbijzijnde vertices bij het gewricht.
Herhaal dit proces voor elk ooglidgewricht.
Schakel over naar de Object-modus, schakel Viewport Shading in om het mesh beter te visualiseren, klik vervolgens op een gewricht om de armature te selecteren.
Schakel over naar de Pose-modus en test de invloeden van het ooggewricht door het gewricht vast te pakken en te verplaatsen. Het mesh volgt op de juiste manier.
Maak controles
Aangezien het maken van hoofden vereist dat je verschillende poses achtereenvolgens opslaat, kunnen controles, hoewel niet vereist, je helpen om je gewrichten snel en effectief te poseren. Je kunt controles maken door externe controllergewrichten toe te voegen die de interne aansturen, waardoor het gemakkelijker wordt om gewrichten te benaderen, te poseren of terug te zetten naar een neutrale transformatie.
Je kunt controles op veel verschillende manieren maken. Het volgende voorbeeld gebruikt Bone Constraints en eenvoudige geometrische vormen die zijn opgenomen in het referentie Blender-project om snel gemakkelijk toegankelijke controllergewrichten voor de gezichtsgewrichten van het karakter op te zetten. Voor meer informatie over rigging en constraints, zie de documentatie van Blender voor details over karakter rigging en object constraints.
Om te beginnen met het maken van gezichtsgewrichtcontroles:
Schakel over naar de Object-modus en selecteer de armature.
Houd Shift + D ingedrukt om de armature te dupliceren, hernoem de duplicaat naar Controller.
Schakel over naar de Bewerken-modus, selecteer alle niet-gezichtsgewrichten, klik met de rechtermuisknop in de viewport en selecteer Verwijder Geselecteerde Gewrichten in het contextmenu.
Batch hernoem de gewrichten om _Con als suffix toe te voegen om ze als controllergewrichten aan te duiden:
- Houd Shift ingedrukt en klik op alle controllergewrichten in de Outliner.
- Navigeer naar Bewerken > Batch Hernoemen. Het Batch Hernoemen-dialoogvenster wordt weergegeven.
- In het dialoogvenster:
- Klik op de Geselecteerde knop.
- Stel het dropdownmenu in op Gewrichten.
- Stel Type in op Stel Naam In.
- Stel Methode in op Suffix.
- Stel Naam in op _Con.
- Klik op de OK-knop.
Stel gewrichtsconstraints in voor elk gezichtsgewricht dat een controller vereist.
- Schakel over naar de Object-modus, selecteer de originele armature.
- Schakel over naar de Pose-modus, klik op het LeftEye-gewricht en navigeer naar het tabblad Bone Constraints in de Properties Editor.
- Klik op het dropdownmenu Bone Constraint, voeg Kopieer Locatie en Kopieer Rotatie toe, en stel in elke constraint:
- Stel de Doel in op Controller.
- Stel Gewricht in op LeftEye_Con.
- In de Kopieer Rotatie-constraint:
- Schakel in As X, Y en Z uit.
- Schakel in Inverted Axis X, Y en Z in.
- Stel Mix in op Offset (Legacy).
- Herhaal dit constraintproces voor elk gezichtsgewricht dat een controller vereist.
- OPTIONEELMaak aangepaste gewrichtsvormen voor gemakkelijker toegang tot de controlegewrichten.
- Schakel over naar de Object-modus, selecteer het Controller-armatureobject.
- Schakel over naar de Pose-modus, selecteer vervolgens LeftEye_Con.
- Navigeer naar het tabblad Bone Properties in de Properties Editor > Viewport Display > Custom Shape, stel vervolgens Custom Object in op WDG_Eye.001. In het referentieproject delen de vormobjecten vergelijkbare namen met de gezichtsgewrichten.
- Stel de X-rotatie in op -90, evenals eventuele extra schaling indien nodig.
- Herhaal dit proces voor al je controllergewrichten. Je kunt de originele gezichtsgewrichten op dit punt verbergen.
- OPTIONEELPas kleurthema's toe op je controllergewrichten, zodat je de gezichtsgewrichten gemakkelijker kunt visualiseren.
Blijf in de Pose-modus, navigeer naar de Outliner en selecteer LeftEye_Con.
Navigeer naar het tabblad Bone Properties in de Properties Editor > Viewport Display > Bone Color, en selecteer een themakleurset.
Herhaal dit proces voor elk controllergewricht, gebruik dezelfde kleur voor de volgende:
- Eén voor LeftEye en RightEye.
- Eén voor LeftUpperOuterEyelid en LeftLowerOuterEyelid.
- Eén voor LeftUpperInnerEyelid en LeftLowerInnerEyelid.
- Eén voor RightUpperInnerEyelid en RightLowerInnerEyelid.
- Eén voor RightUpperOuterEyelid en RightLowerOuterEyelid.
Test je controllers in de Pose-modus.
Pose de gewrichten
Poseren is het proces van het manipuleren van de gewrichten van je hoofdmesh in een specifieke positie per animatieframe. Nadat het hoofd van het model is gerigged, kun je beginnen met het proces van het opslaan van poses in de tijdlijn. Deze gegevens stellen Studio in staat om elke gezichtsbeweging te benaderen en gezichtsposes te animeren of te mengen om dynamische uitdrukkingen te creëren.
Bij het poseren van de gewrichten van het hoofdmesh van je karakter naar nieuwe posities, volg je het Facial Action Coding System (FACS) als referentie voor je gezichtsuitdrukkingsposes. FACS is een uitgebreid, anatomisch gebaseerd systeem voor het beschrijven van alle visueel waarneembare gezichtsbewegingen, en het maakt het mogelijk dat alle gezichtsanimaties deelbaar zijn tussen karakters. Dit betekent dat zodra je een gezichtsanimatie hebt gemaakt, je deze kunt hergebruiken voor elk karakter met een animeerbaar hoofd met een FaceControls-instantie.
Er zijn 50 basisposes die je in Roblox kunt gebruiken om een breed scala aan gezichts-emoties voor je karakters weer te geven, maar slechts een specifieke 17 poses zijn vereist om een dynamisch hoofd op de Marketplace te verkopen. Wanneer je beslist welke poses je nodig hebt, onthoud dan dat de namen van FACS-poses altijd zijn gebaseerd op de oriëntatie van het karakter, niet de camera. Bijvoorbeeld, LeftEyeClosed sluit het linker oog van het karakter, dat zich rechts van het camerabeeld bevindt.
Elk frame binnen de animatietijdlijn van je modelleringssoftware kan één unieke FACS-pose bevatten, dus wanneer je meerdere FACS-poses wilt maken, moet je elke FACS-pose opslaan op een ander frame. Je moet ook een frame opnemen waarop je karakter een neutrale gezichtsuitdrukking heeft met de gezichtscontrollers en gewrichten ingesteld op hun standaardwaarden. Dit zorgt ervoor dat Studio de gewrichtspositieverschillen tussen de neutrale uitdrukking van je karakter en elke FACS-pose kan berekenen.
Om deze reden is het belangrijk om Frame 0 in te stellen als de neutrale uitdrukking van je karakter, en FACS-poses te beginnen met Frame 1. De volgende afbeelding is een voorbeeld van de animatietijdlijn van Blender met 5 frames. Frame 0 heeft de neutrale uitdrukking van het karakter, en frames 1-4 hebben FACS-posegegevens.

De volgende stappen schetsen het proces van het poseren van 5 poses met de gezichtsgewrichten die in onze referentie zijn gemaakt, maar je kunt deze stappen toepassen voor eventuele extra poses voor een expressiever hoofd. Om je gezichtsgewrichten in Blender te poseren:
Zorg ervoor dat de afspeelkop van de animatietijdlijn is ingesteld op het juiste frame.
- Als je de Neutrale pose van het karakter instelt, stel deze dan in op frame 0.
- Als je EyesLookLeft poseert, stel deze dan in op frame 1.
- Als je EyesLookRight poseert, stel deze dan in op frame 2.
- Als je LeftEyeClosed poseert, stel deze dan in op frame 3.
- Als je RightEyeClosed poseert, stel deze dan in op frame 4.
In de Pose-modus, stel de pose in op de maximale positie die je pose realistisch wilt gebruiken:
- Als je de Neutrale pose van het karakter instelt, stel dan de gezichtscontrollers en gewrichten in op hun standaardwaarden,
- Als je EyesLookLeft poseert, selecteer dan beide oogcontrollergewrichten en sleep de ogen naar links van het karakter.
- Als je EyesLookRight poseert, selecteer dan beide oogcontrollergewrichten en sleep de ogen naar rechts van het karakter.
- Als je LeftEyeClosed poseert, selecteer dan beide oogcontrollergewrichten en sleep de linker oogleden naar beneden om de onderste oogleden te ontmoeten.
- Als je RightEyeClosed poseert, selecteer dan beide oogcontrollergewrichten en sleep de rechter oogleden naar beneden om de onderste oogleden te ontmoeten.
Druk in de viewport op A om alle gewrichten te selecteren.
Klik met de rechtermuisknop in de viewport en selecteer Voeg Sleutelframe In met Sleutelset > Locatie en Rotatie. Dit zorgt ervoor dat elk frame de positionele en roterende informatie voor alle gewrichten bevat.
Wanneer alle poses zijn opgeslagen in je tijdlijn, stel je het Begin en Einde van de animatietijdlijn in om het aantal frames met opgeslagen poses weer te geven. Stel altijd Begin in op 0 en, in dit specifieke voorbeeld, kun je het Einde instellen op 4 als je alleen de 4 niet-neutrale voorbeeldposes aan het mappen bent.

Combinatieposes
Je kunt 2-3 basis FACS-poses combineren in een enkel animatieframe om complexe gezichtsuitdrukkingen weer te geven. Wanneer je echter FACS-poses combineert die dezelfde gezichtsregio's aansturen, kunnen de gezichtskenmerken ofwel botsen of de vorm van het karakter vervormen.
Bijvoorbeeld, zowel LeftEyeClosed als LeftCheekRaiser sturen beweging aan rond het linker oog van het karakter: LeftEyeClosed sluit het oog, en LeftCheekRaiser tilt de wang omhoog en duwt het onderste ooglid omhoog, wat een knijpachtige effect veroorzaakt. Wanneer je beide poses combineert met een of meer op 100% van hun waarden, botsen het onderste ooglid en het bovenste ooglid:
Een combinatiepose, of correctieve, is de combinatie van 2-3 FACS-poses die dezelfde gezichtskenmerken in een enkel animatieframe aansturen met een correctief verschil van 100% van hun standaardwaarden. Door een combinatiepose te definiëren en te mappen naar je hoofd, kun je corrigeren hoe je wilt dat de twee of meer FACS-poses combineren. Bijvoorbeeld, als je een correctieve toevoegt voor elk van de vorige gebruiksgevallen, maken de onderste en bovenste oogleden contact met elkaar zonder te botsen:
Bij import berekent Studio het correctieve verschil voor combinatieposes in de FaceControls-instantie van het hoofd, en de FaceControls-instantie corrigeert de basisposewaarden terwijl ze combineren in de Animatie-editor.
Map elke pose
Nadat je elke FACS-pose die je karakter nodig heeft hebt geposeerd, moet je elke animatieframe die je poseert mappen naar de bijbehorende FACS-basis- of combinatieposenaam. Mappen slaat de gewrichtsposities en vertalingen op binnen de hoofd MeshPart, en wanneer je begint met het animeren van je hoofd binnen de Animatie-editor, gebruikt de FaceControls-instantie deze opgeslagen gegevens om de gezichtskenmerken van je karakter naar de toepasselijke FACS-pose te transformeren.
Naast je gezichtsposes, moet je de RootFaceJoint mappen zodat Studio het correct kan lokaliseren en alle kindergewrichten binnen de FaceControls-instantie kan verbergen bij import. Vergeet niet, slechts een specifieke 17 poses zijn vereist om een dynamisch hoofd op de Marketplace te verkopen.
Om je opgeslagen poses en de RootFaceJoint te mappen:
Schakel over naar de Object-modus, selecteer vervolgens Head_Geo.
In het tabblad Object Properties van de Properties Editor, navigeer naar de sectie Aangepaste Eigenschappen, klik vervolgens op de Nieuwe knop. Een nieuwe aangepaste eigenschap verschijnt onder de Nieuwe knop.
Als je Maya gebruikt, kun je de RootFaceJoint en gezichtsposedata mappen met de Extra Attributen in een vergelijkbaar formaat als Blender's Aangepaste Eigenschappen. Om attributen toe te voegen:
- Selecteer het Head_Geo-object en navigeer naar de Attribuuteditor.
- Onder het dropdownmenu Attributen, selecteer Voeg Attributen Toe....

Klik rechts van de nieuwe aangepaste eigenschap op het Tandwielpictogram. Het pop-upvenster Eigenschap Bewerken verschijnt.
In het pop-upvenster:
- Klik op het dropdownmenu Type, selecteer vervolgens String.
- In het veld Eigenschapsnaam:
- Als je de RootFaceJoint mapt, voer dan RootFaceJoint in.
- Als je een pose mapt, voer dan het frame nummer in dat je mapt, bijvoorbeeld Frame0.
- Laat de velden Standaardwaarde en Beschrijving leeg, klik vervolgens op de OK-knop. De nieuwe aangepaste eigenschap wordt bijgewerkt met je nieuwe eigenschapsnaam.
In het veld rechts van de naam van de aangepaste eigenschap:
- Als je de RootFaceJoint mapt, voer dan DynamicHead in.
- Als je een basispose mapt, voer dan de bijbehorende FACS-basispose of combinatieposenaam exact in zoals deze is gespeld.
- Als je een combinatiepose mapt, voer dan elke basispose die je combineert in, gescheiden door een onderstreping, zoals Funneler_JawDrop_Pucker.
Druk op Enter.
Terwijl je dit proces herhaalt, wordt elke extra aangepaste eigenschap die je maakt weergegeven in de sectie Aangepaste Eigenschappen van het tabblad Object Properties van de Properties Editor.

Exporteer je karakter
Nadat je het hoofd van je karakter hebt geposeerd en gemapt, kun je het karaktermodel exporteren als een .fbx om in Studio te importeren, zodat je toegang hebt tot de 4 oogposes met de FaceControls-instantie in Studio. Je kunt ook het volledig geconfigureerde Cubie-hoofd .fbx refereren om toegang te krijgen tot alle 50+ basisposes.
Om het basis hoofdmodel als een .fbx te exporteren:
- Maak in de Outliner alle objecten zichtbaar, maak ze selecteerbaar en selecteer vervolgens alles in je project onder de Objecten-collectie.
- Klik in de bovenbalk op Bestand > Exporteren > FBX (.fbx). Het venster Blender-bestandsweergave verschijnt.
- In de sectie Inbegrepen,
- Schakel Beperk tot > Geselecteerde Objecten in. Merk op dat deze stap optioneel is als je geen extra collecties in je Blender-project hebt.
- Schakel Aangepaste Eigenschappen in.
- In de sectie Armature schakel je Voeg Bladgewrichten toe uit.
- Schakel Animatie in en breid deze uit, schakel vervolgens NLA-strips, Alle Acties en Forceer Start/Einde Sleutelframes uit.
- Klik op de knop Exporteer FBX en sla de .fbx op in de directory van jouw keuze.
Op dit punt kun je nu de .fbx in Studio importeren als een karakter met een ondersteunde animeerbare hoofd. Voor instructies voor modelimport en gebruik, zie Test hoofden in Studio.
